VS Code运行Jupyter报错

时间:2020-9-4 作者:admin


问题描述:

今天在电脑中安装了Python3.8.5环境,然后使用pip安装了ipython和jupyter,没想到在VS Code中使用Jupyter Notebook一直有问题,一直报一个错误:“Unable to start session for kernel Python 3.8.5 64-bit . Select another kernel to launch with.”
同时VS Code中Jupyter Server的状态也一直是busy
VS Code运行Jupyter报错

原因分析:

一开始百思不得其解,直接运行jupyter notebook是正常的,后来在github的vscode python插件讨论区找到了答案。
原地址如下:https://github.com/microsoft/vscode-python/issues/13701
这里在自己的博客中也记录下,是因为traitlets 这个包升级的原因,traitlets 在2020.9.1升级到了5.0版本,可以在https://pypi.org/project/traitlets/#history查看traitlets的版本:
VS Code运行Jupyter报错

解决方案:

根据github中大佬们的指引,将traitlets这个包的版本降回到4.3.3解决

python3 -m pip install traitlets==4.3.3 --force-reinstall

有可能会报错,可以pip的时候添加一下国内源就能解决问题

声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。