vue2.x 和 vue3.x 源码编译

时间:2020-9-19 作者:admin

Vue源码编译

 

vue2.x 源码
 
vue3.x 源码
 

1. vue2.x源码编译错误解决

  • 错误信息:
    error D:\Code\vue\node_modules\phantomjs-prebuilt: Command failed.
    vue2.x 和 vue3.x 源码编译

  • 解决方案,参考log提示。

    github下载,由于网络问题,zip包下载很容易失败,可以手动下载 phantomjs-2.1.1-windows.zip 链接 安装包,并保存到c盘:C:\Users\Administrator\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip路径下即可。

2. vue2.x 和 vue3.x编译

  • 安装依赖

    yarn install

    npm install

  • 编译

    yarn build

    npm run build

3. 编译结果查看

  • vue2.x 在根目录 dist/
    vue2.x 和 vue3.x 源码编译

  • vue3.x 在根目录 packages/vue/dist
    vue2.x 和 vue3.x 源码编译

声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。