windows环境下学会使用conda 创建虚拟环境,解决python版本与库不兼容问题

时间:2020-10-22 作者:admin

windows环境下学会使用conda 创建虚拟环境,解决python版本与库不兼容问题

相信经常使用python的同学,在运行程序的时候,遇到最难以解决,也最麻烦的事就是版本问题,有时候python版本高了,不能向下兼容库的版本,python版本低了,也不能向上兼容库的版本,经常因为这样的问题,不能运行程序。下面学会了anconda conda的使用将几乎解决这个问题。

  1. 创建一个含有你想要的python 版本虚拟环境
conda create -n Python3 python=3.5

#python =XXX  xxx是你指定的python 版本,Python3 是你创建环境的名字
  1. 下面就可以激活环境
conda   activate Python3
#Python3 是你已创建好的虚拟环境

  1. 激活环境后就可以安装所需要的库了
pip install  XXX
XXX为你需要的库
  1. 运行python脚本
python D:/a.python
#a.python放在D盘下
  1. 推出虚拟环境
deactivate
  1. 删除虚拟环境Python3
conda remove -n Python3 --all
  1. 删除虚拟环境Python3中的某个安装包
conda remove --n Python3 xxx
  1. 查看环境列表
pip list
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。